Page 1 of 1

Bypass steam vr for oculus

Posted: Thu Jul 18, 2019 1:38 pm
by Blackjack
The link for open composite is on this article
https://forums.oculusvr.com/community/d ... -in-openvr

Re: Bypass steam vr for oculus

Posted: Thu Jul 18, 2019 6:25 pm
by Bunny
Cheers Matey!

Re: Bypass steam vr for oculus

Posted: Sat Jul 20, 2019 7:23 am
by Blackjack
I’ve got this working perfectly now: Mods working, buttkicker working. Game runs much smoother than with steam vr, a world of difference for me.

Re: Bypass steam vr for oculus

Posted: Sat Jul 20, 2019 3:26 pm
by Bunny
Working good for me too. Def a difference

Re: Bypass steam vr for oculus

Posted: Sat Jul 20, 2019 8:36 pm
by Fritz
Yep, agreed. While I don't see a massive improvement, the improvements I do see are definitely worth it (and frankly it's worth it to avoid SteamVR in any case anyway).

Re: Bypass steam vr for oculus

Posted: Sun Jul 21, 2019 1:27 pm
by Reggie
Would either of you chaps mind sharing your config file?

Re: Bypass steam vr for oculus

Posted: Mon Jul 29, 2019 5:43 am
by Fritz
Okay Blackjack, how are you getting this to work on your end? How do you have it set up? It was working on my system for a couple days, but now I simply cannot get OpenComposite to run IL2 through my Rift no matter what I try. I've tried the full System Wide install, and I've tried installing the .DLL file into IL2 itself... neither with any luck.

What happens is I'll try to start IL2 in Oculus Home, and it starts the usual Home program starting deal (with the IL2 icon), and then it just dumps me back into Oculus Home in the Rift, even though on my desktop IL2 is running in VR mode.

Re: Bypass steam vr for oculus

Posted: Mon Jul 29, 2019 12:04 pm
by Blackjack
Fritz wrote:
Mon Jul 29, 2019 5:43 am
Okay Blackjack, how are you getting this to work on your end? How do you have it set up? It was working on my system for a couple days, but now I simply cannot get OpenComposite to run IL2 through my Rift no matter what I try. I've tried the full System Wide install, and I've tried installing the .DLL file into IL2 itself... neither with any luck.

What happens is I'll try to start IL2 in Oculus Home, and it starts the usual Home program starting deal (with the IL2 icon), and then it just dumps me back into Oculus Home in the Rift, even though on my desktop IL2 is running in VR mode.
I’m not a tech guy Fritz but it sounds like something has gone drastically wrong somewhere. I would completely uninstall OpenComposite and IL2 and start again from scratch.
Sorry mate, I’m not a PC guru so my solution may sound drastic.
All I did was install the OpenComposite program, run it and choose the option to bypass steam vr. I haven’t messed with anything else like the .DLL file or the stuff for settings as I still use OTT.